Linux Lubuntu 14.04 Trusty LTS Solving: “Input/output error”, “Unrecoverable error”, Error (2) Package Issues

September 10, 2014 | By thelinuxevangelist | Filed in: Tutorial.

Repairing Lubuntu 14.04 Trusty LTS Packages Issue

You are Welcome! The Tutorial Shows You Step-by-Step How to Troubleshooting a Linux Lubuntu 14.04 Trusty Tahr LTS i386/amd64 Broken Package.

The Reparation Workflow is Working also in Case of an Apt-get/Dpkg “input/output”, “unrecoverable error” and error (2) Issues!

This is the Ultimate Procedure to Follow for Successfuly Recovering Your Lubuntu System from a Severe Issue.

Linux Lubuntu 14.04 Trusty LTS Solving: 'Input/output error' Package Issue - Featured
  1. First Follow this First-Aid Repairing Procedure

    Troubleshooting Lubuntu Broken System

    The Linked Guide Shows You How to Check Up Your System before this Manual Reparation.

  2. Open Terminal Window
    (Press “Enter” to Execute Commands)

    Ctrl+Alt+t

    Repairing Lubuntu 14.04 Trusty LTS Input/output Package Issue - Open Terminal
  3. Collect a List of the Broken Packages

    sudo su -c "apt-get -f install"

    Find inside the Output and Take Note of All the Packages that are Misbehaving.

  4. Edit the dpkg “status” File

    sudo gedit /var/lib/dpkg/status

    Remove All Blocks Beginning with Package: [myPackageName] and Ended with a Blank Line

    Example:

    Package: libakonadi-kde4
    Status: install ok installed
    Priority: optional
    Section: libs
    Installed-Size: 3047
    Maintainer: Lubuntu Developers 
    Architecture: amd64
    Source: kdepimlibs
    Version: 4:4.13.3-0ubuntu0.1
    Replaces: kdepimlibs-data, kdepimlibs5 (<< 4:4.4.0)
    Depends: libakonadiprotocolinternals1 (>= 1.11.80), libc6 (>= 2.14), libgcc1 (>= 1:4.1.1), libkdecore5 (>= 4:4.13.3), libkdeui5 (>= 4:4.13.3), libkio5 (>= 4:4.13.3), libqjson0 (>= 0.7.1), libqt4-dbus (>= 4:4.6.1), libqt4-network (>= 4:4.5.3), libqt4-sql (>= 4:4.5.3), libqtcore4 (>= 4:4.8.0), libqtgui4 (>= 4:4.8.0), libsolid4 (>= 4:4.13.3), libstdc++6 (>= 4.6)
    Breaks: kdepimlibs-data, kdepimlibs5 (<< 4:4.4.0)
    Description: library for using the Akonadi PIM data server
     This is the client access library for using the Akonadi PIM data server.
     .
     This package is part of the KDE Development Platform PIM libraries module.
    Homepage: http://pim.kde.org/
    Original-Maintainer: Debian Qt/KDE Maintainers 

    Save the File.

  5. Try Again to Repairing System

    sudo su -c "apt-get -f install"

    If Still New Broken Packages are Showing Up then Repeat the Former Step.

    With a More or Less dose of Patience Your Lubuntu Should be Successfully and Happily Recovered :)

  6. Only in Case of No Solution then Recover the old “status” File!

    sudo su -c "cp /var/lib/dpkg/status-old /var/lib/dpkg/status"

Tags: , , , , , , , , , , , , , , ,