How to Install Required Packages for Canon Legacy Driver on Ubuntu 14.04 Trusty

April 22nd, 2018 by thelinuxevangelist

Canon Legacy Driver Dependencies Installation Ubuntu 14.04

Hello Ubuntu User! This Tutorial Shows You Step-by-Step How-to Install Required Packages for Canon Printer Legacy Driver on Ubuntu 14.04 Trusty LTS 32/64-bit GNU/Linux.

This because in origin the Canon Legacy Drivers has been made for Ubuntu 12.04 Precise and so we Need some of those Packages.

How to Install Required Packages for Canon Legacy Driver on Ubuntu 14.04 Trusty - Featured
  1. Open a Terminal Shell emulator window
    Ctrl+Alt+t on Desktop
    (Press “Enter” to Execute Commands)

    How to Install Required Packages for Canon Legacy Driver on Ubuntu 14.04 Trusty - Open Terminal Shell Emulator
  2. Then Install Trusty Packages

    sudo apt install libpango1.0-0 libpng12-0

    If Got “User is Not in Sudoers file” then Look: Solution

  3. Add the Ubuntu Precise Extra Packages Repo

    echo 'deb [trusted=yes] http://cz.archive.ubuntu.com/ubuntu precise main universe' \
     >> /etc/apt/sources.list.d/extra.list
    apt update
  4. Installing libtiff4

    apt install libtiff4:i386 libtiff4
    apt -f install
  5. Restore Ubuntu Trusty LTS Repo

    rm /etc/apt/sources.list.d/extra.list
    apt update
    exit
  6. How-to Install Canon Printers Driver on Ubuntu

    Installed Canon Printer Driver

Tags: , , , , , , , , , , , , , , , , , , , , , , , , , , ,